• Impossible d'activer Curl avec un système Windows 64bit sur Wamp server

    image de l'aticle Impossible d'activer Curl avec un système Windows 64bit sur Wamp server

    Avant de suivre les liens, faites attention quand vous installez une dll dans un dossier programme ou autre part sur votre ordinateur. Vous n'avez aucun moyen de savoir ce que fait réellement cette dll.

    Après avoir eu des problèmes avec la librairie curl de wamp server2 et après quelques recherches la dll "php_curl.dll" contenue dans le répertoire C:\wamp\bin\php\php5.3.13\ext de php ne fonctionnait pas sur un système 64 bit (Windows Seven).

    Vous trouverez la dll de correction à cette adresse http://www.anindya.com/php-5-4-3-and-php-5-3-13-x64-64-bit-for-windows/. Pour ma part c'était la dll php_curl-5.3.13-VC9-x64.zip qui a résolue mon problème.

    Vous devrez ensuite activer curl en faisant clique gauche sur le logo wamp -> php -> PHP extensions -> clique sur php_curl.

14 commentaires

leleuf  20-11-2012

Merci il fallait le savoir ! Je galère depuis 1 demi heure à chercher pourquoi curl ne fonctionne pas

Smoi  12-12-2012

grand merci. J'aurais pu y passer du temps

sniffy  17-01-2013

Merci ! Je ne voyais pas d'où venais le problème, mais c'était un coup des 64 bits.

Mag  05-02-2013

1 heure de recherche et voilà la solution.
Grand merci :)

John  06-02-2013

Merci c'est vraiment une solution utile. Dommage que wamp ait laissé passé ce genre d'erreur.

Ster Trak  20-03-2013

Comment le faire fonctionner ?

Tosh  25-03-2013

Y a-t-il un bouton "j'aime" ?
Merci!!!

Lordounet  02-05-2013

Merci !! Après un aprem de galère c'était plus simple que d'aller dans les php.ini.
Il suffit de prendre un des 4 derniers liens marqué : Fixed curl extensions en bas de page.

Darkwarrios  29-10-2013

Tu me sauves la vie ! Je galère tellement depuis quelques temps pour un script, la je venais de tomber sur un dernier problème, celui du cURL qui marchait pas ... MERCI !

dodone  04-11-2013

Merci beaucoup !

Thierry  12-11-2013

Un grand merci, et j'en profite pour remercie tous les contributeurs du Web qui m'aident chaque jour !!!!!

benoit  05-03-2014

C'est LA solution. Ca vaut le coup de réinstaller wampserver avant de faire la manipe.

henry  31-03-2014

MERCI INFINIMENT ça fais 2 jours que je comprend pas pour quoi j'arrive pas a faire des api --'.
encore merci !

Alassane  17-06-2014

merci mais je l-ai télécharger mais je sais pas comment faire aprés l'avoir déziper

Laissez un commentaire

* Votre e-mail ne sera jamais utilisé ou donné à un tiers

Recherche

Catégories

Newsletters

Archives